You are viewing a single thread.
View all comments
34 points
*

This is the only way;

if (condition) {
    code
}

Not

if (condition)
{
    code
}

Also because of my dyslexia I prefer variable & function names like this; ‘File_Acces’ I find it easier to read than ‘fileAcces’

permalink
report
reply
4 points
*

I’ve only seen the second type in C#, to be fair it makes code neater but i’m glad I left it for Java.

permalink
report
parent
reply
4 points

I think it would be a much hotter take if you had the opposite opinion. I’ve only met a few of those.

permalink
report
parent
reply

I’m not a programmer (I tried learning programming and unity but got lazy so…) but when I learned about if-then statements, the second one seemed like the way it’s supposed to be; I mean it looks so clean and simple. Do actual programmers prefer the first method?

permalink
report
parent
reply
2 points

I prefer the first method because it reduces the number of empty lines I have to scroll past and visually filter out

permalink
report
parent
reply
0 points

The 2nd is the style guide used in C#, and therefore what you’ve encountered in unity.

permalink
report
parent
reply
3 points

It depends for me. If the condition is some goofy ahh multiline syntax hell i like to use the second option.

permalink
report
parent
reply
1 point

Even then - ) { on a newline.

permalink
report
parent
reply

I use all 3.

If it’s very short and there’s 2 or more in a row, I’ll put it all in one line.

If there’s a bunch of nested if statements, I’ll use the second.

If neither of those conditons, I’ll use the first.

permalink
report
parent
reply

Programming

!programming@programming.dev

Create post

Welcome to the main community in programming.dev! Feel free to post anything relating to programming here!

Cross posting is strongly encouraged in the instance. If you feel your post or another person’s post makes sense in another community cross post into it.

Hope you enjoy the instance!

Rules

Rules

  • Follow the programming.dev instance rules
  • Keep content related to programming in some way
  • If you’re posting long videos try to add in some form of tldr for those who don’t want to watch videos

Wormhole

Follow the wormhole through a path of communities !webdev@programming.dev



Community stats

  • 1

    Monthly active users

  • 555

    Posts

  • 2.8K

    Comments